内容纲要

本篇主要综合汇总下当下我们云服务器系统下,各个Windows系统版本中对SQL安装的最低支持何最高支持版本的总结。

  • SQL2000版本
    Windows2003,Windows2008R2系统都支持。没有特殊的版本要求如要.NET这些。需要注意的是Windows2008系统安装时候比较特殊和复杂。会存在兼容问题。具体安装可以参考:https://www.jb51.net/article/40745.htm
    Windows2012及其以上系统不支持安装。

  • SQL2005版本
    Windows2003,Windows2008R2系统都支持。系统中需要留意先安装.NET2.0版本软件。详细的安装要求参考:https://docs.microsoft.com/zh-cn/previous-versions/sql/sql-server-2005/ms143506(v=sql.90)
    Windows2012系统支持安装,但安装需要使用到SQL2005-SP4版本的sqlservr.exe和sqlos.dll。具体参考http://tech.powereasy.net/Item.aspx?id=3681
    Windows2016及其以上系统不支持安装.
    详细的安装要求参考:https://docs.microsoft.com/zh-cn/previous-versions/sql/sql-server-2005/ms143506(v=sql.90)

  • SQL2008R2版本
    这里我们忽略SQL2008,建议安装SQL2008R2版本.SQL2008因为存在的bug比较多。安装中不有利于所以不建议使用。
    Windows2003Windows2008R2Windows2012Windows2016支持安装。需要安装 .NET3.5。需要留意是Windows2003系统如果安装了MSXML 6 Service Pack2 (KB973686)补丁需要卸载了才能安装成功。

  • SQL2012和SQL2014版本
    Windows2003Windows2008系统不支持
    Windows2008R2-SP1版本系统才支持安装。如果不是SP1版本需要安装下补丁KB976932。这里需要特别注意。下载地址:https://www.catalog.update.microsoft.com/Search.aspx?q=KB976932
    Windows2012及其以上系统支持安装。安装注意需要.NET3.5

特别注意:

  1. SQL的版本选择安装最好是和系统版本契合的。比如Windows2008R2就安装SQL2008R2.

  2. Windows2008R2安装高版本的SQL(如:SQL2012,SQL2014)时候,最好想确定系统是否是Windows2008R2-SP1版本,或者是否安装了KB976932补丁。
    3.文件下载时候确保完整性。安装SQL时候最好选择企业版进行安装,并且安装最好是安装在非系统磁盘下。

补充资料:
SQL安装KEY密钥:https://soft.landui.com/2003.txt
SQL下载文件:https://soft.landui.com/SQL%20Server/
微软官方参考:https://docs.microsoft.com/zh-cn/previous-versions/sql/

可参考下表,下表来源雷霆运维文章:http://l-t.run/629.html

windows server 2003 R2 windows server 2008 R2 windows server 2012 R2 windows server 2016 windows server 2019 微软官网链接
SQL2000 支持 支持 不支持 不支持 不支持
SQL2005 支持 支持 不支持 不支持 不支持 链接地址
SQL2008 支持 支持 不支持 不支持 不支持 链接地址
SQL2008R2 支持 支持 支持 不支持 不支持 链接地址
SQL2012 不支持 支持 支持 不支持 不支持 链接地址
SQL2014 不支持 支持 支持 支持 支持 链接地址
SQL2016  
SQL2017
不支持 不支持 支持 支持 支持 链接地址
SQL2019 不支持 不支持 不支持 支持 支持 链接地址